PLE forum

Full Version: OLE DB error while writing data to file
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Affected: Ple4Win v4.2.0
Reproducible: Always

Click on rename on the Multi Graph definition "Default". Change this to "Diam " without the quotes and press Enter. After this you will get a bug message. If your definition contains a space at end of the definition, you will get this issue.

[attachment=309]
Please supply more details, we are unable to reproduce the issue here. With several projects we could rename "Default" to any other name with space(s) at the end without problems. It doesn't matter whether the definition is empty or not.
(30-05-2012, 03:18 PM)Dr. J Foerster Wrote: [ -> ]Please supply more details, we are unable to reproduce the issue here. With several projects we could rename "Default" to any other name with space(s) at the end without problems. It doesn't matter whether the definition is empty or not.

Steps to reproduce the issue is given below:

Step 1: Open a project file with Multi Graphs in it;
Step 2: Go to the definition "Default";
Step 3: Click on the rename button;
Step 4: Give the name "Diam " without the quotes. This definition name contains a space character at the end of the name;
Step 5: Press Enter.

After step 5 the bug message will occur which is given in the first post.

When you close the project file, this unhandled program error will appear:
[attachment=313]

P Herwig MSc

Even with the additional details we are unable to reproduce this issue. Grateful if you can let us know whether you can still reproduce this behaviour in a recent version of Ple4Win.
(29-03-2016, 11:46 AM)P Herwig MSc Wrote: [ -> ]Even with the additional details we are unable to reproduce this issue. Grateful if you can let us know whether you can still reproduce this behaviour in a recent version of Ple4Win.

This bug still exist in Ple4Win Professional v4.3.1 build 15032.

I have expanded the steps to reproduce it in the latest version:
Step 1: Open a project file with Multi Graphs in it;
Step 2: Go to the definition "KLS" for example;
Step 3: Click on the rename button;
Step 4: Give the name "Diam " without the quotes. This definition name contains a space character at the end of the name;
Step 5: Press Enter;
Step 6: Go to the definition "DEADW" for example;
Step 7: Click on the rename button;
Step 8: Give the name "Diam" without the quotes. This definition name contains no space character at the end of the name;
Step 9: Press Enter.

[attachment=762]

Can you reproduce it now. The issue occurs when you have two definitions "Diam " and "Diam". With and without the space character.

Can you reproduce it now?

P Herwig MSc

Shaswin, thanks! I am able to reproduce the issue following your new step-scenario. Now I can work on a fix.
Nice.

P Herwig MSc

In the upcoming release leading and trailing spaces are removed in a new Multigraph definition (including copy & rename), solving your issue.
Paul,

This topic can be closed.