PLE forum
Issues importing Excel tables in Ple4Win - Printable Version

+- PLE forum (http://www.ple4win.nl/forum)
+-- Forum: Support (http://www.ple4win.nl/forum/forumdisplay.php?fid=5)
+--- Forum: Ple4Win User Interface (http://www.ple4win.nl/forum/forumdisplay.php?fid=29)
+--- Thread: Issues importing Excel tables in Ple4Win (/showthread.php?tid=545)



Issues importing Excel tables in Ple4Win - shaswin - 14-06-2016

Affected version: Ple4Win Professional v4.4.0 build 16050 revision May 26th, 2016

I have attached the Excel import file where some issues are occuring.

Issue 1:
When one imports input tables from Excel and some notes are written in Excel outside the Ple4Win input table range Ple4Win gives a warning (for example the ORIGIN table), see screenshot below. It shouldn't check for data values outside the fixed range of an input table.
[attachment=799]
This worked in earlier version of Ple4Win, somehow the behaviour is changed and a warning is now displayed, which is irritating and not relevant.

Issue 2:
Another is issue when there are a lot of texts outside the input range for example the SUBSIDE input table the data will not get imported. You will see that the SUBSIDE table is empty. You have to remove all your notes to make it work. This worked in earlier version of Ple4Win, somehow the behaviour is changed now.
When for example a formulae is written in column D and E in the SUBSIDE table a #REF warning will appear. Why doesn't PLE doesn't convert the data into a text value before importing?


RE: Issues importing Excel tables in Ple4Win - P Herwig MSc - 15-06-2016

Hi Shaswin, thanks for reporting this issue. I agree that you don't want messages/warnings about data outside the column range. I will take a closer look into what is going on here by the end of this week.


RE: Issues importing Excel tables in Ple4Win - shaswin - 17-06-2016

Thanks.


RE: Issues importing Excel tables in Ple4Win - P Herwig MSc - 17-06-2016

Shaswin, grateful if you can provide additional details as we are unable to reproduce the described behaviour. We have no issues at all when importing the supplied Excel file.


RE: Issues importing Excel tables in Ple4Win - shaswin - 17-06-2016

(17-06-2016, 12:47 PM)P Herwig MSc Wrote: Shaswin, grateful if you can provide additional details as we are unable to reproduce the described behaviour. We have no issues at all when importing the supplied Excel file.

Try it again with the attached file. I had uploaded an updated Excel file in post #1 with an updated SUBSIDE table, which may be the reason the error was gone.
I have now removed row 1 and 2 from the SUBSIDE table, where now text is written in the first line behind the table and a #REF value is used. Try it again.
I am now not in office and can't test it.


RE: Issues importing Excel tables in Ple4Win - P Herwig MSc - 17-06-2016

No issues with this second Excel file as well...


RE: Issues importing Excel tables in Ple4Win - shaswin - 21-06-2016

(17-06-2016, 01:52 PM)P Herwig MSc Wrote: No issues with this second Excel file as well...

Paul, I can reproduce the issue with the second Excel file.

You can reproduce it by the following steps:
Step 1: Open Ple4Win;
Step 2: Save a new empty project file;
Step 3: Import the second Excel file using the Ple4Win menu. After Importing you will see a blue color legend data in the SUBSIDE input table, see screenshot below:
[attachment=815]

After clicking on the SUBSIDE table you will see an empty input table, which is not the case in the second excel file.

[attachment=816]

Can you confirm that you can reproduce the issue...


RE: Issues importing Excel tables in Ple4Win - P Herwig MSc - 22-06-2016

Got it! Apparently this behaviour depends on the settings of the Ple4Win Options. If you would enable the Test mode under the Advanced Ple4Win Options you will notice the issues are gone.

I will resolve the issues in the source code right away (J-1897).


RE: Issues importing Excel tables in Ple4Win - shaswin - 22-06-2016

Okay nice. The issue will be resolved soon. Thanks.