This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Default values doesn't work when a cursor is blinking in a cell
03-04-2012, 01:07 PM, (This post was last modified: 31-05-2012, 10:30 PM by shaswin.)
#1
Default values doesn't work when a cursor is blinking in a cell
Affected version: Ple4Win v4.2.0
Reproducible: Always

When you have a blinking cursor in for example in the SETL-F cell you the values button doesn't works. You won't get the default value 1.1.

   

Workaround is to move you cursor in an anothor cell and click on the default values icon.

Other input tables (with default values in it) are also affected. If this is by design, then why not enabling the default values by removing the cursor and then pasting the default value in the cell. It shouldn't matter if the cursor is blinking in the cell. This would reduce one extra handling for the user.
07-05-2012, 10:43 AM,
#2
RE: Default values doesn't work when a cursor is blinking in a cell
If a blinking cursor is present in a cell, the program expects user input, not data from the program itself.
We made this distinction on purpose, to make sure the program doesn't change cell data the user is currently working on.

If you are in a cell and want to use the default values-button, just hit <Esc> once. You will leave the editing mode of the cell (it is still selected), and the default value is then added as you wished.

I hope this clarifies this issue.
07-05-2012, 01:31 PM, (This post was last modified: 07-05-2012, 01:37 PM by shaswin.)
#3
RE: Default values doesn't work when a cursor is blinking in a cell
Consider you have a value 0 in the SETL-F cell. Test the table.
Now delete the value in the SETL-F cell with the Backspace and press then the Esc button.
You will see that the value "0" will appear again, so you can't use the default values anymore for this cell.

24-03-2016, 03:43 PM,
#4
RE: Default values doesn't work when a cursor is blinking in a cell
Note that the <Esc> key will also cancel changes made to the cell being edited. After removing the "0", leave the cell (e.g. click another cell and hit <Esc> to leave edit mode there or simply click the Workspace panel title). The cell is now blank empty and - if not in edit mode - will accept the default value.


Forum Jump:


Users browsing this thread: 1 Guest(s)