Export Multiple Tables

When a user wants to export one or more data tables from Ple4Win into a single Excel file, an interactive 'wizard' kind of functionality will guide the user through each step of the process. Each data table exported from Ple4Win can be found as a table in an individual worksheet in the Excel file. The order of the worksheets can be given during the export process.

There are 2 ways to activate this functionality:

Select from menu File > Export > Tables to Excel file...

Export Excel Button On File

or,

Click on (the arrow next to) the 'Multi Table' Tools.MTable.16x16 button and select Export Excel 16 'Export to Excel File...'

Multi Table Button On Toolbar Export

'Multi Table: Export' screen will be shown. This functionality consists of 3 steps. However, it is not necessary to go through all the steps. The first step is sufficient to export multiple tables to an Excel file. Default settings will be used for the remaining 2 steps.

Click to expand/collapseStep 1: Select the table(s) to be exported

A general working procedure about the tab Selection can be found in section Multi Table Selection.

In the Export mode, all available tables can be selected to be exported. Output/Result tables are available only if the concerning design function has been successfully processed. If empty tables are hidden (checkbox 'Show Empty tables' is unchecked), design functions containing only empty tables are disabled (grey).

Legend of the used icons in the Export mode is shown below.


Table is empty

Table contains data

Input table

Input Table Green Empty

Input Table Green Filled

Output/Result table

Output Table Yellow Empty

Output Table Yellow Filled

History table

History Table Empty

History Table Filled

Status table

Info Table Empty

Info Table Filled

Warning table

Warning Table Empty

Warning Table Filled

Click Next to specify the export options or click on the Export button to export the selected table(s) immediately.

Load Multi Table Definition

A general working procedure about loading a definition can be found in Multi Table Definition.

The following settings will be loaded into the 'Multi Table: Export' dialog screen depending on the selected definition type:

Selected definition type

Settings to be loaded:

Selection, Options and Layout settings

tab Selection: selected tables, the tree selection view option and the 'Show Empty tables' option

tab Options: selected 'Rows to be printed' options for each selected result (output) table

tab Layout: output sequence of the selected tables

Selection and Layout settings

tab Selection: selected (input) tables and the 'Show Empty tables' option

tab Options: none

tab Layout: output sequence of the selected (input) tables

Selection settings only

tab Selection: selected (input) tables only

tab Options: none

tab Layout: none

Click to expand/collapseStep 2: Specify the data row(s) of each selected table

A general working procedure about the tab Option can be found in section Multi Table Option.

Click Next to specify the table order or click Previous to add or remove table(s) to be exported. To export the selected table(s) to Excel file immediately, just click on the Export button.

Click to expand/collapseStep 3: Set the table (sheet) order

A general working procedure about the tab Layout can be found in section Multi Table Layout.

Save the Current Multi Table Definition

A general working procedure about saving a definition can be found in Multi Table Definition.

Settings that will be saved in the 'Multi Table: Export' definition are:

1. Selection settings

settings of the first tab Selection (selected tables, the tree selection view options and the 'Show Empty tables' option)

2. Options settings

settings of the second tab Options ('Rows to be printed' options for the selected result (output) tables)

3. Layout settings

settings of the last tab Layout (output sequence of the selected tables)


Last changed: 14/09/2016