Print Multiple Tables

This Multi Table functionality will give the users the ability to print multiple data tables from Ple4Win. A selection of data rows, the print order and the print layout of each individual table can also be specified.

There are 2 different ways to activate this functionality:

Select from menu File > Print > Tables...

Print Tables Button On File

or,

Click on (the arrow next to) the 'Multi Table' Tools.MTable.16x16 button and select Export Print 16 'Print...'

Multi Table Button On Toolbar Print

'Multi Table: Print' screen will be opened. This functionality consists of 3 steps. However, it is not necessary to go through all the steps. The first step is sufficient to print multiple tables. Default settings will be used for the remaining steps.

Click to expand/collapseStep 1: Select the table(s) to be printed

A general working procedure about the tab Selection can be found in section Multi Table Selection.

In the Print mode, all available tables can be selected to be printed. Output/Result tables are available only if the concerning design function has been successfully processed. If empty tables are hidden (checkbox 'Show Empty tables' is not selected), design functions having only empty tables are disabled (grey).

Legend of the used icons in the Print mode is shown below.


Table is empty

Table contains data

Input table

Input Table Green Empty

Input Table Green Filled

Output/Result table

Output Table Yellow Empty

Output Table Yellow Filled

History table

History Table Empty

History Table Filled

Status table

Info Table Empty

Info Table Filled

Warning table

Warning Table Empty

Warning Table Filled

Click Next to specify the print options or click on the Print button to print the selected table(s) immediately.

Load Multi Table Definition

A general working procedure about loading a definition can be found in Multi Table Definition.

The following settings will be loaded into the 'Multi Table: Print' dialog screen depending on the selected definition type:

Selected definition type

Settings to be loaded:

Selection, Options and Layout settings

tab Selection: selected tables, the tree selection view option and the 'Show Empty tables' option

tab Options: selected 'Rows to be printed' options for each selected result (output) table

tab Layout: output sequence of the selected tables and, if available, the 'Print table(s) on new page' option for the selected output tables

Selection and Layout settings

tab Selection: selected (input) tables and the 'Show Empty tables' option

tab Options: none

tab Layout: output sequence of the selected (input) tables

Selection settings only

tab Selection: selected (input) tables only

tab Options: none

tab Layout: none

Click to expand/collapseStep 2: Specify which data row(s) to be printed

A general working procedure about the tab Option can be found in section Multi Table Option.

Click Next to specify the print order or click Previous to add or remove table(s) to be printed. To print the selected table(s) immediately, just click on the Print button.

Click to expand/collapseStep 3: Set the print sequence

A general working procedure about the tab Layout can be found in section Multi Table Layout.

Save the Current Multi Table Definition

A general working procedure about saving a definition can be found in Multi Table Definition.

Settings that will be saved in the 'Multi Table: Print' definition are:

1. Selection settings

settings of the first tab Selection (selected tables, the tree selection view options and the 'Show Empty tables' option)

2. Options settings

settings of the second tab Options ('Rows to be printed' options for the to be printed tables)

3. Layout settings

settings of the last tab Layout (output sequence of the selected tables and the 'Print table(s) on new page' options for the to be printed tables)


Last changed: 14/09/2016