Title Bar and Main Toolbar

Title Bar and Main Toolbar

The window title bar at the top of the Ple4 Win main window is showing the program name and the name of the project database currently in use (if any). Below it the main toolbars are located, which allow access to all functions of the program.

Note that all functions can be accessed through the top text-based toolbar (the menus). Frequently used functions are also accessible through the buttons located on the icon-based toolbars below the menus.

Note further that any of the toolbars can be moved around and (un)docked by click-and-drag on its corresponding ToolbarMove icon. All toolbars can also be modified by either right-clicking anywhere on any of the toolbars or by clicking on one of the ToolbarMod icons.

Below is a screen capture of the main window title bars.

windowtitlebar

For information on menu items and icons, see the list below.

Menu items

File menu items:

TmainFNew New...

Open a file dialog to create a new, empty project database.

TmainFOpen Open...

Open a file dialog to select an existing project database (*.plex).

TmainFOpen2 Open Secondary...

Opens a file dialog to select an existing project database as secondary database.

TmainFSave Save

Save the current project database.

Empty16 Save As

Open a file dialog to save the current project database under a new name or at a different location.



Empty16Import               SubmenuPointer

 

Empty16 Empty16 Project from Secondary...

Copy data from the secondary database into the current project database. A selection can be made which part of the database is to be copied. Only available if a secondary database has been opened.

Empty16 Empty16 Function from Secondary

Copy all input data of the currently active design function from the secondary database into the current project database. Data already existing in the project database is not overwritten. Only available if a secondary database has been opened.

Empty16 Empty16 Tables from Excel File...

Import input data from an Excel file into the current project database. Existing data in input tables will be overwritten unless the input tables are locked.

Empty16Export               SubmenuPointer

 

Empty16 Empty16 Tables to Excel File...

Export multiple data tables from current project database into a single Excel file. Each data table exported from Ple4Win can be found as a table in an individual worksheet in the Excel file.

Empty16 Empty16 Template to Excel File...

Create an (empty) Excel file that can be used to import input data into Ple4Win.



TmainPPage Page Setup...

Set printing options.

TmainPPrint Print             SubmenuPointer

 

Empty16 Empty16 Current Open Table...

Print data in currently active workspace panel.

Empty16 Empty16 Tables...

Print multiple data tables.



Empty16 Close Project

Close active project without closing Ple4Win.

 

 

Empty16 (List of recent projects)

Display the names of the most recently used projects. The number of projects listed here can be changed in the Ple4Win Options

 

 

Empty16 Exit

End program.

 

View menu items:

Empty16 Roadmap

Show / hide the roadmap panel.

Empty16 Overview

Show / hide the function overview panel.

Empty16 Workspace

Show / hide the workspace panel.

Empty16 Other panels               SubmenuPointer

 

Empty16 Empty16 Roadmap Legend

Show / hide the roadmap legend

Empty16 Empty16 Messages

Show / hide the messages panel



History.Icon History-table

Show / hide the History-table.

Status.Icon Status-table

Show / hide the Status-table.

Warnings.Icon Warnings and Errors-table

Show / hide the Warnings & Errors-table.



LayoutDef Default View

Rearrange and show all panels in the default layout.

LayoutMax Maximise Workarea

Rearrange and unpin all panels in such a way that the size of the workspace panel is maximised.



LayoutLoad Load Layout

Load a previously saved panels layout and applies it.

LayoutSave Save Layout

Save the current panels layout to file. Any previously saved layout will be overwritten.

 

Project menu items:

Empty16 Function 1

Switch to design function 1 (project setup).

Empty16 Function 2

Switch to design function 2 (pipeline configuration).

Empty16 Function 3.1

Switch to design function 3.1 (pipe data).

Empty16 Function 3.2

Switch to design function 3.2 (soil data).

Empty16 Function 3.3

Switch to design function 3.3 (model boundary).

Empty16 Function 4.1

Switch to design function 4.1 (wave/current loading).

Empty16 Function 4.2

Switch to design function 4.2 (pipeline loading).

Empty16 Function 5

Switch to design function 5 (pipeline behaviour).

Empty16 Function 6.1

Switch to design function 6.1 (cross-section data).

Empty16 Function 6.2

Switch to design function 6.2 (cross-section behaviour).



TmainProcess Process

Process all design functions until finished or encountered an error.

 

Wizards:

Empty16Soil Model Wizard

Starts the Soil Model Wizard.

 

Tools menu items:

TmainVisualisationVisualisation

This functionality will display the configuration in 3D as a greyed pipeline. The configuration can be zoomed in and out, panned in any direction and rotated in any direction as well.

TmainDraw Pipeline Draw

Show a schematically drawing of the pipeline defined in the workspace panel. Depending on how far the project has been processed, additional information such as the displaced pipeline are also available.

TmainMGraph Multi Graph

Show the multi graph data in the overview panel.

Tools.MTable.16x16 Tables               SubmenuPointer

 

Empty16 Empty16 Print...

Print multiple data tables.

Empty16 Empty16 Export to Excel File...

Export multiple data tables from current project database into a single Excel file. Each data table exported from Ple4Win can be found as a table in an individual worksheet in the Excel file.

Empty16 Empty16 Import to Excel File...

Import input data from an Excel file into the current project database. Existing data in input tables will be overwritten unless the input tables are locked.

Empty16 Empty16 Template to Excel File...

Create an (empty) Excel file that can be used to import input data into Ple4Win.

TmainOptions Options...

Show the Ple4Win options and settings window.

 

Help menu items:

TmainHCont Contents...

Show the contents-page of this help.

TmainHSearch Search...

Show the search-page of this help.

HardwareKey 16x16 Hardware Key

Show the Hardware Key help (only available in Ple4Win Professional).

Empty16 Visit Ple4Win website

Opens a browser window to http://www.Ple4Win.com


 

Ple4Win.Icon About...

Show an informational window about Ple4Win.


ToolbarMain, last changed: 14/09/2016

See also:

Main Screen